New User Confirmation Email
Incident Report for ForgingBlock
Resolved
This incident has been resolved.
Posted Sep 19, 2020 - 23:28 MST
Investigating
We found there are some issues associate with Confirmation Email when new users register to Dashboard. We are currently investing the issue will update soon. This issue only impacts new users. Existing merchants will be not impacted.
Posted Sep 19, 2020 - 11:23 MST
This incident affected: MainNet Dashboard (dash.forgingblock.io).